Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 a 10 de 19
  1. #1

    "Removi" o DMG-6661, tendo Vivo fibra com Internet e TV

    Ae povo, acabei de me cadastrar no forum e, sinceramente, não li as regras nem me apresentei :P, mas já li o fórum algumas vezes, pois estava procurando a famosa solução de substituir o roteador D-link DMG-6661 que a vivo coloca no Vivo Fibra.
    Uma breve apresentação: sou de Santos-SP, fanático por tecnologia, mas um pouco preguiçoso.

    Logo de cara, já aviso: não retirei o DMG-6661, no sentido de "ele está desligado da tomada", mas sim no sentido "minha internet não depende dele, minha TV sim".

    Tem algum tempo que tenho 2 internets, uma da NET/Virtua (que tenho há muito tempo) e uma da Vivo, que tenho há no máximo 2 anos (não lembro). Pra utilizar as duas internets, juntas (sim, somada), utilizo o roteador Cisco RV320, que é um roteador de internet para pequenas empresas, que aceita 2 WANs por cabo (e mais 2 por 3G/4G).

    No final do ano passado, fiz uns ajustes nos planos que tenho e meu Vivo Fibra mudou pra 100 Mbps com a TV, que trás "de brinde" o D-link DMG-6661 e aí me vi com um problema... Como levar a internet da Vivo, pro meu roteador principal? Senão eu perderia o balanceamento entre as internets.

    Pois bem... Já sabia que o modem mandava a internet pela VLAN 10 e a TV pela VLAN 20. Procurei bastante e não achei nada. O que mais achei aqui no forum era "se é fibra com TV, esquece".
    O que fiz... (pra começar, salvei as configurações de todos os equipamentos, pra voltar se precisasse)
    - Liguei o modem na porta 1 de um switch que aceita VLANs (pode ser um roteador com openwrt, dd-wrt, etc)
    - Configurei a porta 1 desse switch pra ficar nas VLANs 10 (net) e 20 (TV)
    - Configurei a porta 2 pra ficar nas VLANs 20 (TV) e 1 (minha rede)
    - Configurei a porta 3 pra ficar na VLAN 10 (net)
    - Conectei a porta 2 do switch na WAN (porta de internet) do DMG-6661
    - Conectei a porta 3 do switch na WAN 2 do meu roteador principal (a WAN 1 fica na NET/Virtua). Se o "switch", nesse caso, for substituído por um roteador com Openwrt, essa conexão não seria necessária, já que o próprio roteador "trataria" a internet.
    - No DMG-6661:
    -- Fui em LAN Setup e troquei o IP do roteador, mudando ele de rede, pois a rede que vem nele é a mesma que eu uso. Apesar de ser um IP interno, não sei se posso cita-lo como um exemplo aqui.
    -- Por conta dessa mudança, "cacei" todos os lugares do roteador, em que tinha alguma referência ao IP original. Não lembro quais alterei e quais ele próprio alterou, mas sei que ele existe em:
    --- Advanced, DHCP Server, Primary DNS Server e IP Router
    --- Advanced, DHCP Server, Conditional Serving Pool, clique em "Edit" no único item em "Existing Conditional Serving Pool", aí ele aparece em "IP router"
    --- Nesse mesmo lugar, por conta dessa mudança, também alterei o "IP Range" (novamente, não sei se posso informar os IPs aqui)
    --- Advanced, Routing, Policy Route, clique em "Edit" no único item do "Routing Table", troquei o "Source IP Address" pro primeiro IP do Range acima
    -- Os passos, do DMG-6661, até aqui só foram necessários pois a minha rede usa o endereçamento igual ao que vem nele, e daria problema. Continuando...
    -- Removi a conexão PPPoe, pois ela não é mais necessária pra mim (essa configuração é feita no roteador de internet)
    -- Criei uma nova conexão, na interface eth5, com:
    --- VLAN ID 1 e VLAN Priority 0
    --- Static IP Address, dando pra ele um IP da minha rede de casa, com a subnet e gateway de casa
    --- Marquei a opção "Default Route"
    --- Troquei o "DNS Mode" pra "Manual DNS", colocando os DNS que eu queria (no caso, o do meu roteador principal)
    -- Em Advanced, Security, criei uma nova interface de nome "WAN1_FIREWALL", selecione a interface "eth5.1 (WAN1&route)", em Type deixei In, em Default Action coloquei "Permit" (opção minha)
    -- Criada a interface, fui em Firewall rules e criei uma regra pra permitir ping. Pra isso é só selecionar a interface "eth5.1 (WAN1&route)", setar como Enabled, Protocol ICMP, Action Permit, ICMP Type any.
    -- No meu roteador principal, defini uma rota estática pra essa rede, dizendo que o roteador pra chegar nela seria o DMG-6661 (o IP, da minha rede, que dei pra ele na configuração acima)
    -- Ainda no meu roteador principal, liberei a passagem dessa rede nova pra qualquer das outras redes (inclusive a internet)
    Pronto...
    Nada bonito, nada simples, mas funcionando.

    Pô Renato, mas por que você não colocou só um switch separando a 10 da 20, devolvendo a 20 na WAN do DMG-6661?
    Isso foi o que eu fiz inicialmente e a TV funcionou normalmente, mas depois descobri que o Video on Demand (Vivo Play) dependia do decoder da TV enxergar a internet (pelo menos para os trailers e capas dos filmes, não cheguei a tentar alugar)

    Tá, mas preciso de um switch com VLANs?
    Não, acredito que um roteador que aceite VLANs, como os que tem openwrt e dd-wrt, poderia ser configurado no lugar do Switch

    Se eu sei remover TOTALMENTE o DMG-6661, substituindo ele por outro roteador?
    Não. Acredito ser possível, mas sem a ajuda da Vivo, só fuçando e lendo muito, pra entender o funcionamento da IPTV. O site do Openwrt fala brevemente sobre o que eles chamam de "X Play", é só fuçar lá. Como falei lá em cima, sou preguiçoso e não tenho porque me livrar totalmente dele, eu só queria que a internet entrasse (com o IP público dela) pelo meu roteador principal.

    Não fiz um tutorial bonitinho, com passo a passo bem detalhado, fiz mais pra dar um norte. Se alguém se interessar, de repente até faço um com todos os passos detalhados, incluindo utilizar um openwrt no lugar do Switch (ou tentar, né? porque usei o switch direto :P).

    Espero ter ajudado

  2. #2
    Nível 84: Homem de Aço Avatar de mmelo76
    Desde
    Feb 2016
    Localização
    Caieiras - SP
    Posts
    7.448
    Bo, dia @rccvilla...muito boa a sua dica...técnica e objetiva!
    Galaxy Note 9 512GB + 128GB + Dex Station
    Dell XPS 18 Portable AIO 18.4 Multi-touch
    i3 | 12GB RAM | 480GB SSD - Windows 10 Pro
    Designer Bluetooth® Desktop
    É novo no Fórum? Seja Bem Vindo! e dê um Oi para Galera
    Apresente-se aqui! e Curtir posts ajuda aumentar seu nível no Fórum...

  3. #3

    Dúvidas

    Boa tarde amigo, estou tentando replicar sua configuração mas não está funcionando, vc poderia postar a parte dos IPS que vc usou, apenas os internos. Obrigado.

  4. #4
    Bom dia @Amatakas
    Minha rede usa o endereçamento 192.168.1.0/24 , que é o mesmo endereçamento usado pelo roteador da vivo.
    Eu optei por trocar o endereçamento do roteador da Vivo, então...
    Na configuração da LAN dele, ele passou a ser 192.168.2.1 (ao invés de 192.168.1.1). Como disse no post inicial, alterei todos os lugares que apareciam o IP original (ou qualquer referência à rede 192.168.1.0), para esse novo IP (ou um IP da nova rede).
    O que seria a configuração da WAN1 dele, eu tirei o pppoe e coloquei uma interface com endereço estático, ficando 192.168.1.254, mascara 255.255.255.0, gateway 192.168.1.1, DNS 192.168.1.1.
    Sendo assim, ele ficou com 3 interfaces ativas: 1 LAN, com IP 192.168.2.1, uma WAN1 com IP 192.168.1.254 e a WAN 2, que eu não mexi, que é a rede da IPTV.
    Feito isso, criei uma rota estática no meu roteador principal, "avisando" que a rede 192.168.2.0/24 era encontrada através do roteador da vivo:
    endereço: 192.168.2.0
    Mascara: 255.255.255.0
    Gateway: 192.168.1.254
    Sem configurar essa rota estática, a comunicação não funciona, basicamente pq o roteador da vivo saberia que precisa sair pelo 192.168.1.1, mas o roteador principal não saberia devolver o tráfego da rede 192.168.2.0/24

  5. #5
    Obrigado pelo retorno, irei testar novamente no final de semana.

    Acredito que deva ser algo na rota.

  6. #6

  7. #7
    Nível 84: Homem de Aço Avatar de mmelo76
    Desde
    Feb 2016
    Localização
    Caieiras - SP
    Posts
    7.448
    Citação Postado originalmente por Amatakas Ver Post
    Obrigado pelo retorno, irei testar novamente no final de semana.

    Acredito que deva ser algo na rota.
    Uma dica @Amatakas

    Gostou do tópico / Resposta / ajuda?

    É só curtir. Isso melhora sua pontuação e da pessoa que te ajudou!
    Galaxy Note 9 512GB + 128GB + Dex Station
    Dell XPS 18 Portable AIO 18.4 Multi-touch
    i3 | 12GB RAM | 480GB SSD - Windows 10 Pro
    Designer Bluetooth® Desktop
    É novo no Fórum? Seja Bem Vindo! e dê um Oi para Galera
    Apresente-se aqui! e Curtir posts ajuda aumentar seu nível no Fórum...

  8. #8
    Boa tarde.

    Estava tentando adaptar a sua idéia utilizando um router da Asus (AC68U) que possui suporte a Vlan e um Switch com suporte a Vlan (SG180e), já utilizava essa solução separando Vlan 10 e 20, uso a internet no Asus e a TV no Dlink, mas toda a parte de interatividade da TV não funciona.

    Por enquanto ainda não consegui adaptar, inclusive na sexta-feira a noite estava realizando alguns testes, acabou dando algum problema que tudo parou de funcionar, hehehe, teve que vir o técnico e apenas ele entrando em contato com a gerencia para reconfigurar tudo, kkkkk.

    Bom, de qualquer forma obrigado, vou continuar tentando, só tomando alguns cuidados adicionais para não derrubar tudo de novo.

    Abraço.

  9. #9
    @rccvilla muito bom o tópico!

    Seja bem vindo ao Fórum Vivo.
    Precisa de ajuda? Fale com os coordenadores do Fórum: @_bruna e @angelojunior

  10. #10

    Funcionou!

    Oi Renato (@rccvilla),

    Obrigado pelas dicas! Tenho o roteador dissociado da TV a algum tempo, mas havia perdido as funções interativas.
    Seu guia foi o norte perfeito!
    Fiz um pouco diferente, tenho um Asus AC87 com asuswrt merlin. Ele não permite configurar a vlan 20 via interface gráfica, mas consegui fazê-lo via ssh.
    Então não precisei do switch e configurei as vlan, a única coisa a mais que fiz, foi na vlan1. Configurei a porta de saida para o DMG como tagged. Tudo funcionando e um switch burro a menos na rede!

    :-D

Tags para este Tópico